Rechtstracker.at

Anl. 2 SigV

Fassungen
03.02.2000 bis 30.12.2004 — BGBl. II Nr. 30/2000 (Stammfassung)
InkrafttretenAußerkrafttretenKundmachung
Anl. 203.02.200030.12.2004 BGBl. II Nr. 30/2000 (Stammfassung) · aufgehoben durch BGBl. II Nr. 527/2004

Rechtstracker.at · Quelle: RIS (Bundeskanzleramt)

Diese Fassung ist nicht aktuell

Kurztitel

Signaturverordnung

Kundmachungsorgan

Bundesgesetzblatt Teil 2, Nr. 30 aus 2000, aufgehoben durch Bundesgesetzblatt Teil 2, Nr. 527 aus 2004,

Typ

V

Paragraph/Artikel/Anlage

Anlage 2

Inkrafttretensdatum

03.02.2000BGBl. II Nr. 30/2000

Außerkrafttretensdatum

30.12.2004aufgehoben durch BGBl. II Nr. 527/2004

Abkürzung

SigV

Index

20/12 Urkunden

Text

Anhang 2

Technische Verfahren und Formate

  1. Ziffer eins
    Technische Verfahren der Aufsichtsstelle

Bei der Aufsichtsstelle ist als Hashverfahren das Verfahren SHA-1 und zur Verschlüsselung des Hashwerts das Verfahren RSA einzusetzen (Hauptsystem). Die Verwendung des Chinese Remainder Theorem (CRT) ist nicht zulässig.

Werden von der Aufsichtsstelle zusätzlich andere Signaturerstellungsdaten eingesetzt (Paragraph 3, Absatz eins, vorletzter Satz), so muss es sich bei den entsprechenden Verfahren zur Verschlüsselung des Hashwerts um solche für sichere elektronische Signaturen handeln.

  1. Ziffer 2
    Hashverfahren für sichere elektronische Signaturen

Folgende Hashverfahren werden als sicher anerkannt:

  1. Litera a
    RIPEMD-160,
  2. Litera b
    Funktion SHA-1.

Diese Hashverfahren sind bis 31. Dezember 2005 für den Einsatz bei elektronischen Signaturen als sicher anzusehen.

Diesen Hashverfahren sind andere Verfahren gleichgestellt, die zumindest die gleiche Sicherheit aufweisen und von einer Bestätigungsstelle als solche anerkannt und veröffentlicht wurden.

  1. Ziffer 3
    Verfahren zur Signaturerstellung (Verschlüsselung des Hashwerts) für sichere elektronische Signaturen

Folgende Verfahren zur Signaturerstellung werden als sicher anerkannt:

  1. Litera a
    RSA,
  2. Litera b
    DSA,
  3. Litera c
    DSA-Varianten, die auf elliptischen Kurven basieren:
    • Strichaufzählung
      ISO/IEC 14883-3, Annex A.2.2 ("Agnew-Mullin-Vanstone analogue"),
    • Strichaufzählung
      IEEE-Standard P1363, Abschnitt 5.3.3 ("Nyberg-Rueppel version"),
    • Strichaufzählung
      IEEE-Standard P1363 [5], Abschnitt 5.3.4 ("DSA version").

Für die Umsetzung sind nach Möglichkeit international anerkannte Methoden zu verwenden.

Die genannten Algorithmen sind bis 31. Dezember 2005 für den Einsatz bei elektronischen Signaturen als sicher anzusehen.

Diesen Verfahren zur Signaturerstellung sind andere Verfahren gleichgestellt, die zumindest die gleiche Sicherheit aufweisen und von einer Bestätigungsstelle als solche anerkannt und veröffentlicht wurden.

  1. Ziffer 4
    Formate für sichere elektronische Signaturen

Die für sichere elektronische Signaturen eingesetzten Formate sollten einem international anerkannten Standard oder einer anerkannten Empfehlung (zB PKCS#7 Cryptographic Message Syntax Standard) entsprechen.

  1. Ziffer 5
    Formate für qualifizierte Zertifikate

Die European Electronic Signatures Standardization Initiative (EESSI) ist derzeit damit beschäftigt, Formate und Normen für die Darstellung qualifizierter Zertifikate sowie für deren Inhalte auszuarbeiten. Vorläufig wird empfohlen, international anerkannte Normungsvorschläge (zB römisch zehn.509 v3 certificate oder römisch zehn.509 v2 CRL for use in the Internet) anzuwenden. Die detaillierte Ausprägung des Formats ist im Sicherheits- und Zertifizierungskonzept darzustellen. Zur Beschreibung ist eine Formale Notation (zB CCITT bzw. ITU-T Recommendation römisch zehn.208: Specification of Abstract Syntax Notation One - ASN.1 - 1988) zu verwenden. Dies gilt auch für die Codierung der Kennzeichnung "qualifiziert" in einem qualifizierten Zertifikat.

  1. Ziffer 6
    Formate für Verzeichnis- und Widerrufsdienste für qualifizierte
Zertifikate

Die Verzeichnis- und Widerrufsdienste sollten in einem international anerkannten Format geführt werden. Für den Zugang zu den Verzeichnis- und Widerrufsdiensten werden insbesondere folgende internationale Normen empfohlen:

  1. Litera a
    1988 CCITT (ITU-T) römisch zehn.500 / ISO IS9594,
  2. Litera b
    RFC 2587 Internet römisch zehn.509 Public Key Infrastructure LDAPv2 Schema,
  3. Litera c
    RFC 2459 Internet römisch zehn.509 Public Key Infrastructure Certificate and CRL Profile,
  4. Litera d
    RFC 2589 Lightweight Directory Access Protocol (LDAPv3) Extensions for Dynamic Directory Services.

Schlagworte

Verzeichnisdienst, Sicherheitskonzept

Gesetzesnummer

20000370

Dokumentnummer

NOR40003809